Aktualizace z phpBB 3.0.x na phpBB 3.1

 Přihlášení



 Hodiny
 Lajkni stránku na ...
 Poslední témata

Aktualizace z phpBB 3.0.x na phpBB 3.1

Nový příspěvekod leschek » čtv úno 06, 2014 12:18 am

Aktualizace z phpBB 3.0.x na phpBB 3.1

Následující článek popisuje můj způsob aktualizace z phpBB 3.0.12 na phpBB 3.1, ale rozhodně to neznamená, že fórum nejde aktualizovat jinak, možná i jednodušeji. Návod je aktuální pro aktualizaci na phpBB 3.1.0 RC4 a v novějších verzích můžou být nějaké změny, které aktualizaci zjednodušší.

    Poznámka: Článek jsem psal pro aktualizaci z phpBB 3.0.12, ale měl by platit pro všechny phpBB 3.0 verze. Na phpBB.com jsem četl, že se podařilo aktualizovat i phpBB 3.0.0 na phpBB 3.1. V každým případě ale platí: zálohovat, zálohovat, zálohovat....
  Po několika testovacích aktualizací z phpBB 3.0.12 na phpBB 3.1 jsem zjistil, že několik problémů, které se mohou po aktualizaci objevit lze docela snadno eliminovat nastavením stylu originálního fóra na prosilver, což je i výchozí styl v phpBB 3.1 a nastavením jazyka na angličtinu, nebo pokud použijete češtinu z tohoto fóra, můžete postupovat podle tohoto návodu. Sám měním nastavení výchozího stylu a jazyka v administraci (použije se pro nepřihlášené) i v uživatelském panelu (použije se po mém přihlášení). Po aktualizaci lze v administraci snadno doinstalovat nové vzhledy a jazyky. Pokud je fórum ve špatném jazyku (takovém, který není pro phpBB 3.1 dostupný) může se zobrazit podobná hláška:

Kód: Vybrat vše
Language file ./language/cs/common.php couldn't be opened.

Pokud se vám to stane, tak je asi nejjednodušší zkopírovat obsah složky "language/en" do složky "language/cs".

MODy z phpBB 3.0.x se v phpBB 3.1 nepoužívají, protože jsou nahrazeny "rozšířeními", takže po aktualizaci na phpBB 3.1 nemusí některé funkce, které byly přidány MODy do phpBB 3.0.x fóra fungovat. Na druhé straně by MODy nainstalované ve fóru ve většině případů neměly vadit, takže byste neměli přijít o žádné nastavení, které je uloženo v databázi a později, až bude z MODu vytvořeno rozšíření zase funkci ve fóru mít. Při aktualizaci fóra s cca + 30 MODy jsem ale narazil na několik výjimek, kdy jsem musel MODy před aktualizací úplně odinstalovat (i z databáze - vlastně jen z databáze, protože soubory se úplně nahradí novými. Více o něco dál).:

  • Advanced BBCode Box 3 - s tímto MODem se sice můžete později do aktualizovaného fóra přihlásit, ale při zobrazení příspěvků, ve kterých jsou použity nějaké zvláštní BBKódy se zobrazí jen bílá stránka s chybovou hláškou. Proto je lepší MOD předem odinstalovat. Sice přijdete o formátování, ale budete moci alespoň příspěvky zobrazit. Autor MODu už pracuje na rozšíření, které by mělo většinu funkcí MODu do fóra vrátit (kromě několika BBKódů jako anchor, tabs, table atd., zmenšování obrázků, nastavení v administraci atd.).
  • Auto Backup - tento MOD dělá trošku potíže, když se povolí jako rozšíření (chybová stránka v administraci). Takže ho je zatím lepší odinstalovat před aktualizací z phpBB 3.0.x, nebo pokud na to zapomenete můžete ho jako rozšíření (v administraci) zakázat, smazat jeho data a pak znovu povolit - tímto by měl taky začít fungovat. Dá se očekávat, že autor nějak tento menší problém časem vyřeší. Naštěstí nejsou u tohoto MODu žádná důležitá data, která by později nešlo obnovit.
  • Advanced Multi Language Pack Support MOD - tento MOD upravuje relace (sessions) a pokud smažete jeho soubory ze serveru (viz dále) tak budete mít problém, abyste se do fóra přihlásili, respektive zůstali přihlášení. V tomto MODu není moc nastavení a tak nebude problém ho nainstalovat až bude dostupný jako rozšíření pro phpBB 3.1. Taky jsem zjistil, že tento MOD je dobrý odinstalovat jako poslední, protože ho nestačí odinstalovat z databáze, ale musí se upravit i soubory, ve kterých jsou provedeny změny tímto MODem. Pokud to neuděláte, tak se nebudete moci přihlásit.
V phpBB 3.1 je několik MODů z phpBB 3.0.x nahrazeno funkcí, která se nachází přímo ve fóru, proto není třeba mít některé MODy nainstalované. Taky můžete této příležitosti (aktualizace) využít k tomu, že si trochu pročistíte databázi a odinstalujete z ní nepoužívané MODy (o soubory se není třeba starat - více o kousek níž), nebo zastaralé MODy, u kterých se nedá očekávat, že je autor aktualizuje na "rozšíření". Například já osobně odinstaluju následující:
  
  • "NV Who was here?" - Autor nebude pokračovat ve vývoji, ale už se objevilo rozšíření, které ho nahradí. V každým případě tento MOD neobsahuje žádná důležitá data a je velmi jednoduché ho nastavit.
  • NV Recent topics" - Tento MOD jsem už v phpBB 3.0.x nahradil MODem cBB Blockgets, který zrovna tuto funkci tak dobrou nemá, ale stačí to. cBB Blokcgets ještě pro phpBB 3.1 není, ale dá se očekávat, že autor MOD aktualizuje.
    Aktualizace: Už se pracuje i na rozšíření Recent Topics.
  • "NV newspage" - žádná důležitá data a MOD zle snadno nastavit. Autor už pracuje na rozšíření.
  • "phpBB Statistics" - Dobrý statistiky, ale už dlouho neaktualizovaný, takže těžko říct, jestli budou jako rozšíření pro phpBB 3.1. Navíc v MODu nejsou uchovány žádný důležitý data.
    Aktualizace: pro phpBB 3.1 se pracuje na rozšířeních, která jsou jiná, ale mohli by původní statistiky nahradit. Jsou to rozšíření Board statistics a Posts Statistics
  • "Paypal Donation MOD" - MOD už nepoužívám a nejsou v něm žádná důležitá data (neprobíhá žádná sbírka). Pokud se nepletu, tak existuje blok v cBB Blockgets, který umí dary.
  • "ACP Announcement Centre" - Tenhle MOD jsem už dávno nahradil blokem v cBB Blockgets. Těžko říct, jestli ho autor aktualizuje na rozšíření.
    Aktualizace: Existuje rozšíření "Board Announcements", které je sice jiné než původní MOD, ale funkčně by ho mohlo nahradit.
  • "Smashable Christmas Lights" - tohle je taková blbůstka pro období vánoc, bez které se obejdu a není třeba mít MOD nainstalovaný.
  • "mChat Bot" - Myslím, že autor nebude aktualizovat tento MOD na rozšíření pro phpBB 3.1. Na druhé straně může být v tomto MODu spousta dat, která se odinstalací smažou. Osobně mi to nevadí, ale někomu by mohlo.
Aktualizace z phpBB 3.0.12 na phpBB 3.1

Pozn. Psáno v době, kdy bylo phpBB 3.0.12 nejnovější. Od té doby bylo vydáno phpBB 3.0.13 a 3.0.14 pro které tento postup platí taky.

Pokud se do aktualizace pustíte, nezapomeňte zálohovat soubory na FTP i databázi.
  
Nejjednodušší způsob aktualizace je smazání všech souborů starého fóra ze serveru (MODy a styly z phpBB 3.0.x nelze obecně použít na phpBB 3.1), kromě souboru config.php (slouží k propojení souborů na serveru a databáze) a složek images (jsou v ní uloženy třeba avátary, smajlíci atd.), store a files (slouží k uložení příloh). Kromě toho některé MODy mají vytvořeny zvláštní složky, ve kterých jsou uložené další soubory (např. MOD phpBB Gallery vytvoří složku /gallery/images/, ve které jsou obrázky z galerie a Download MOD vytvoří složku /downloads/, ve které jsou soubory ke stažení), takže nezapomeňte na serveru tyto složky taky nechat.

Po smazání souborů se do složky nahrají soubory phpBB 3.1 (kromě souboru config.php, protože chcete zachovat ten původní). Potom přejděte ve vašem vyhledávači na adresu
  
Kód: Vybrat vše
http://www.vase_domena.cz/phpBB31/install/database_update.php


Zobrazí se stránka se spoustou řádků, na jejímž spodku uvidíte tlačítko "Continue database uprade" - pozn.: tohle se mi často nezobrazuje, mám rovnou hlášku, že je aktualizace databáze hotová (více o něco málo níž).

283

Když na něho kliknete, tak by se měla databáze aktualizovat a naspodu stránky byste měli vidět hlášku "Database updater has completed!"

284

spolu s vysvětlením, že jste tímto krokem aktualizovali pouze databázi a ne soubory. Protože jsme ale už soubory aktualizovali (smazali je a nahradili novými z phpBB 3.1) není důvod se tím moc zaobírat a můžete přejít na vaše aktualizované fórum vyzkoušet, jestli všechno funguje. Pokud ano, tak můžete podle návodu [url]tady[/url] nainstalovat novou češtinu. Kromě toho taky doporučuju smazat jazykové balíčky (na stejné stránce jako instalace jazykových balíčků), které nemáte aktualizované pro phpBB 3.1.
  
Pokud jste měli ve vašem phpBB 3.0.x fóru nainstalované nějaké MODy, které jste neodinstalovali, tak je docela možné, že budete mít v administraci a uživatelském a moderátorském panelu povolené moduly patřící k MODům. Vypadá to nějak takhle:

285

Po kliknutí na takovou záložku (ale platí to i pro záložku MODy, což může být problém, pokud nainstalujete nějaké rozšíření, které bude mít nastavení na záložce MODy) se vám zobrazí podobná chyba:

Kód: Vybrat vše
Všeobecná chyba
Cannot find module ./../includes/acp/acp_blockgets.php

BACKTRACE


FILE: (not given by php)
LINE: (not given by php)
CALL: msg_handler()
atd.

Pochopitelně je dobré takový moduly zakázat. To se udělá jednoduše v "Administraci" - záložka "Systém" - "Správa modulů" - vybrat Administraci (pokud je modul v administraci) - najít modul a kliknout na "Zakázat", což modul zakáže, takže bude nerušeně odpočívat a čekat až bude nainstalováno rozšíření, které ho opět aktivuje:

286

Po zákazu modulů by měl modul z předchozí pozice zmizet:

287

Pozor na to, že některé moduly můžou mít podmoduly (např. modul "ACP_BLOCKGETS"), které je taky třeba zakázat. Některé moduly se taky můžou nacházet v jiných nadřazených modulech - nejčastěji modul ".MODy".
  
Relativně bezpečné testování pomocí kopie databáze #

Následující popis lze použít i pro bezpečnou aktualizaci (zůstane vám původní fórum) z phpBB 3.0.x fóra na phpBB 3.1.0.

V phpMyAdminu přejděte na databázi, kterou chcete kopírovat a na záložce "Operations" ("Úpravy") najdete možnost "Copy database to" ("Zkopírovat databázi na"), pomocí které můžete zkopírovat vaši databázi do nové databáze.

288 289

Vložte název vaší databáze a zatrhněte, že chcete zkopírovat "Strukturu a data" a přidat hodnotu AUTO_INCREMENT a potvrďte vaše nastavení kliknutím na tlačítko "Go" ("Proveď"). Pak počkejte, až se vytvoří kopie vaší databáze.

Dalším krokem je nahrání nových souborů na server. Asi nejbezpečnější je vytvořit nový adresář, do kterého chcete phpBB 3.1 instalovat a nahrát do něho soubory fóra, které jste zkopírovali. Pak v souboru config.php upravte položku

Kód: Vybrat vše
$dbname = 'predpona_nazevnovedatabaze';

Tím byste měli propojit kopii souborů na FTP s kopií databáze. Pak smažte na FTP cache, kromě souborů .htaccess a index.htm (pokud přesunete i staré cache, tak se můžete přesměrovávat na původní fórum). Zkontrolujte, jestli všechno funguje tak jak má (po přihlášení se podívejte do adresního řádku prohlížeče, jestli jste pořád ve zkopírovaném fóru - nemusíte si přesměrováni na původní fórum všimnout, protože fóra vypadají skoro stejně. Taky zkontrolujte příspěvky, administraci atd.). Pokud ano, tak nastavte v administraci správnou cestu ke skriptům a název cookie, který by se měl lišit od původního fóra (taky neuškodí "Smazat všechny cookies fóra a pročištění cache prohlížeče (Ctrl+F5)). Pak můžete nové fórum aktualizovat na phpBB 3.1 jak je popsáno nahoře. Pokud máte problémy s přesměrováním a nepomůže ani promazání cache na FTP, tak můžete zkusit v kopii databáze, kterou jste vytvořili, v tabulce phpbb3_config v řádku script_path změnit původní cestu ke skriptům na složku na serveru, ve které budete mít soubory fóra, které chcete propojit s nově vytvořenou databází. Původně je tam složka, ve které je původní fórum. Další věc, která by mohla dělat problémy je název cookie, který můžete změnit ve stejné tabulce v řádku cookie_name.

Poznámka: Zjistil jsem, že nejjednodušší je to udělat nějak takto:

  1. Na serveru vytvořit tři složky, do jedné nahrát kopii originální fóra, do druhé nahrát čisté phpBB 3.0.12 bez MODů a do třetí nahrát phpBB 3.1.
     
  2. Propojit soubory config.php ze všech tří složek (fór) s kopií databáze původního fóra (viz výše).
     
  3. Přejít na kopii originálního fóra a odinstalovat z kopie původní databáze všechny MODy (spuštěním instalačního souboru MODu), které dělají problémy, nejsou potřeba nebo neobsahují důležitá data (například nebudu odinstalovávat blog, Galerii a MOD cBB Blockgets, protože v blogu a galerii jsou příspěvky a obrázky, o které bych jinak přišel a v cBB Blockets mám vytvořené bloky, o které nechci přijít. Na druhé straně odinstaluju výše zmíněné MODy).
     
  4. Změnit nastavení jazyka na angličtinu nebo [url]alternativní češtinu[/url] a výchozího stylu fóra i svého stylu na prosilver.
     
  5. Přejít na složku s čistým phpBB 3.0.12 a vyzkoušet, jestli všechno funguje (odhlašování, přihlašování, zobrazení příspěvků, administrace, uživatelský a moderátorský panel, atd.). Pokud ne, promazat cache a popřípadě se vrátit do složky s celou kopií původního fóra a opravit problémy.
     
  6. Pokud všechno funguje přejít na složku s phpBB 3.1 a spustit aktualizaci.
     
  7. Pokud nové phpBB 3.1 nefunguje, smažu kopii původní databáze, vytvořím novou kopii databáze a postup opakuju s tím, že jsem se poučil z předchozích chyb.
     
  8. Pokud chcete požít nové phpBB 3.1 jako hlavní fórum a staré phpBB 3.0.x nechat jako zálohu, přejmenujte na FTP složky s fórama (staré za nové a obráceně) a upravte v administraci správnou cestu ke skriptům. Promazání cache fóra i prohlížeče a smazání všech cookies fóra taky neuškodí.
Uživatelský avatar
leschek
Administrátor
 
Příspěvky: 659
Obrázky: 476
Registrován: ned říj 23, 2005 11:22 pm
Tykání: Ano
TagyphpBB 3.1,phpBB3.1,aktualizace

Re: Aktualizace z phpBB 3.0.x na phpBB 3.1

Nový příspěvekod LachtanDrak » sob úno 25, 2017 2:55 pm

Pokouším se o aktualizaci fora 3.0.14 na 3.1.10 již 14 dní dle všech dostupných návodů bohužel stále se mi nedaří je nějaká možnost pomoci?
LachtanDrak
 

Re: Aktualizace z phpBB 3.0.x na phpBB 3.1

Nový příspěvekod leschek » ned úno 26, 2017 11:36 am

Pomoct se určitě dá. Napiš v čem přesně je problém?
Uživatelský avatar
leschek
Administrátor
 
Příspěvky: 659
Obrázky: 476
Registrován: ned říj 23, 2005 11:22 pm
Tykání: Ano


  • Podobná témata
    Odpovědi
    Zobrazení
    Poslední příspěvek

Zpět na Podpora phpBB 3.1

Přihlásit se  •  Registrovat


cron